Blockada stopped working on Galaxy S10

Hey girls and guys, I have an issue with blokada blocking adds. There seems to be an issue with the blokada VPN connection.

  1. Where did you download Blokada from?
    Blockada.org (newest version of major release 4)

  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Galaxy S10, EU version, Android and 10, Build number QP1A.190711.020 G973FXXU8CTG4

  3. Please explain the issue as detailed as possible. Also include patterns you observed.
    Blokada worked fine for at least a year now. Since yesterday it did not connect to its virtual VPN connection. In other words, while the blokada app said: “Blokada is active” the virtual VPN connection was not in use. Consequently no adds where blocked and the app stated: “0 blocks” while running.

What I did to track down the issue: 1 restarted the device, 2 deleted blokada cache, 3 reinstalled blokada (after restarting the device without blokada being installed), 4 restarted device, allowed all possible permissions including notification, storage, and background usage /activity (Samsung App power management), 5 enabled blokada dns server, 6 enabled the optiona “Allways on VPN” and “Block connections without VPN” in the blockada vpn connection (this leads to no data being transmitted / no internet access, Also android warns that the Allways on VPN connection is “disabled”).

  1. Since when are you facing this issue?
    Yesterday

  2. Did you already try to solve the issue somehow? If so: please state what you did.
    See 3.

1 Like

I have the same question. My mobile phone is S10+

Hello everyone, I have the same device :slight_smile:

Let’s do a bit of troubleshooting.

First things first:
Turn off "block connections without VPN"

Why? See the following

Also @HirIMogul @Ivan_Wang do your phones have the August update? This bit of info is important.

yes, my phone has August update. Is there any solution to make it normal after update?

Same for me on 10e, does not work after the update Today

August update funsies. Try any other vpn application and see if it works.
If not you’re owning one of the device which Samsung broke using the august update. You’ll probably have to hope for a Hotfix

1 Like

Yes, it’s the August update. I turned off “block connections without VPN”. I can use the internet when this option is turned off, but no adds are blocked.

I have a second VPN connection (IPsec) to my server which works just fine.

Thanks for your help

Some folks in the german Blokada telegram group contacted Samsung about this issue.
They were told that it’ll get fixed with the next monthly update.
You can use our workaround in the meantime:

2 Likes

I could make blokada to connect to its local VPN again, simply by deleting the second (sim2) WhatsApp version (which came pre-installed) and than restarting the phone. I have no idea what those two things have in common, but I thought it might be worth mentioning.

Great news!

I’ve just installed Samsung’s latest update (Security Update Sept. 1st) and Blokada works perfectly on it. Obviously, Samsung did indeed fix that VPN bug with its latest security update.

Just to let you know, I have a Samsung Galaxy S10+, running Android 10, Security Patch 1st September 2020.

This was not an automatic update. I was not prompted to install it even though I have auto download enabled. (Just so people know.) I had to manually get the phone to look for it! I found it through Settings_Biometrics and security_Security Update.
You may also find it through Settings_Software Update.

4 Likes

Hi. I still haven’t received the September update and I’m having problems with the workaround.
I’ve tried everything except the abd command which I have no idea how to do it. Can anyone help? Samsung S10 over here.

Hello and welcome to the community:)
Someone said that disabling the Dual Messenger fixed his problems. Did you already try that?

Nope. Still nothing. Can’t connect to VPN

Then you will have to use the command with ADB. Did you manually search for the update (I think that’s possible but am not sure)?

Just jumping in to say that it is manually possible to check for updates. Go to settings->system updates-> check for updates.

1 Like

Yes I searched manually but I don’t have it for my phone. Still August update.
How do I use adb? Is that a app to install? And if so, which? There’s a bunch of them in the play store…

Unfortunately this is not an app on your phone but you need to connect your device with a PC. You will need to follow this guide: https://www.xda-developers.com/install-adb-windows-macos-linux/.
And then follow the instructions in this article: What to do if Blokada won't activate / start?.

It started working out of nowhere! Don’t know exactly what happened, but must have had something to do with the VPN settings because it was the only thing I edited.

1 Like

Oh?^^ okay, well then let’s hope it’ll stay this way:D!

1 Like