Apple Music streaming issues

Having issues streaming Apple Music when Blokada is enabled. I have goodbye ads and adaway enabled. I whitelisted everything I see Apple and I still cannot stream music via Apple Music.

Please advise.

By whitelisting do you mean in Host log? Did you bypass Apple Music in User Apps?

1 Like

Everything I saw from Apple I white listed. Can you please advise what I need to do? Is there a way to white list the entire app all together?

From my understanding you cannot bypass apps on iOS unfortunately. Also both Goodbye ads & Energized lists include adaway in them already. So you can disable that specific list.

You said you whitelisted everything from apple in the host log. Have you tried whitelisting any other domain that Apple Music connects to on opening? Perhaps there is a server that does not contain the word apple in it that the app needs to connect to.

Hi,

I kept checking and I did not see anything else being blocked from Apple specifically. I find it hard to believe that nobody else is having issues with Apple Music?

Hey there, welcome to our community :slight_smile:

Although I don’t currently have an Apple Music subscription, I tried browsing and playing a previously purchased song and also radio stream without issues.
I’ve also tried with and without Blokada Plus (stockholm) activated.

Did you see any red entries in Activities tab after trying to stream? Notice it may take a couple of seconds before it shows.
Try swipe closing the Music app as well as toggling flight mode for a couple of seconds to see if there’s some temporary glitch?

If you still have issues, try disabling Adaway and Goodbye ads one at a time to see if it changes anything. Please allow at least 10 seconds between tests

I believe I did that, but I can look again. Just turn everything off and only open Apple Music.

I find it hard to believe that nobody else is/was having issues streaming Apple Music.

I’m using AdGuard pro now and it works fine.

Alright, let me know. I’d be happy to try to find out the reason for this issue.
I haven’t heard about it before, but not everyone are spending the time to report these bugs.

Is the issue solved by now?

No, the issue is still there.

I have good bye ads and phishing army enabled. Everything I saw that is Apple I whitelisted. Weird thing is some playlists work, while others don’t.

Would you mind digging into this? You’d need to install and try to use Blokada though

Hello there:)
any news on this issue:)?