Api request error

Hi I started getting “api request error” today on my phone, before this day everything has been working perfectly.

I tried to trouble shoot this:
Disable blokclists one by one, no change
Switch to different DNS, no change
Kill the app and delete cache and program data, no change

I get the Api error when I switch to any of the menus inside bloada.

My setup:

Blokada 6.2.0, (I started with version 5 downloaded from the blokada.org, got auto updated to 6)
Stock Android 13 (Latest for OnePlus 8 Pro)
Keep alive on
Ping networks off
Cloudflare DNS, malware blocking
Blocklists: Phishing Army, Exodus Privacy, Developer Dan’s Hosts
Encrypt DNS on
Private DNS off
Always-on VPN on
Block connections without VPN off
Carrier: DNA (in Finland)

The log is rather long, this is the part that keeps repeating:
06:53:06.135 W Dialog Ignoring new dialog request, one is already being displayed
06:53:07.886 W Pack Packs are stale, re-downloading
06:53:07.887 E Pack Packs download disabled for debugging! XXX
06:53:07.889 Filtering Reloading blocklist
06:53:08.020 Filtering Reloaded: 523940 hosts, + user: 0 denied, 0 allowed
06:53:13.840 Blocka User has been informed about the error: Api request failed: Required value ‘device_tag’ missing at $
com.squareup.moshi.JsonDataException: Required value ‘device_tag’ missing at $
at com.squareup.moshi.internal.Util.missingProperty(Util.java:660)
at model.DevicePayloadJsonAdapter.fromJson(DevicePayloadJsonAdapter.kt:67)
at model.DevicePayloadJsonAdapter.fromJson(DevicePayloadJsonAdapter.kt:23)
at com.squareup.moshi.internal.NullSafeJsonAdapter.fromJson(NullSafeJsonAdapter.java:41)
at retrofit2.converter.moshi.MoshiResponseBodyConverter.convert(MoshiResponseBodyConverter.java:46)
at retrofit2.converter.moshi.MoshiResponseBodyConverter.convert(MoshiResponseBodyConverter.java:27)
at retrofit2.OkHttpCall.parseResponse(OkHttpCall.java:243)
at retrofit2.OkHttpCall.execute(OkHttpCall.java:204)
at retrofit2.DefaultCallAdapterFactory$ExecutorCallbackCall.execute(DefaultCallAdapterFactory.java:108)
at service.BlockaApiService.responseOrThrow(BlockaApiService.kt:138)
at service.BlockaApiService.responseOrThrow$default(BlockaApiService.kt:135)
at service.BlockaApiService$getDevice$2.invokeSuspend(BlockaApiService.kt:58)
at service.BlockaApiService$getDevice$2.invoke(Unknown Source:8)
at service.BlockaApiService$getDevice$2.invoke(Unknown Source:2)
at service.BlockaApiService$runOnBgAndMapException$result$1.invokeSuspend(BlockaApiService.kt:166)
at kotlin.coroutines.jvm.internal.BaseContinuationImpl.resumeWith(ContinuationImpl.kt:33)
at kotlinx.coroutines.DispatchedTask.run(DispatchedTask.kt:106)
at kotlinx.coroutines.scheduling.CoroutineScheduler.runSafely(CoroutineScheduler.kt:571)
at kotlinx.coroutines.scheduling.CoroutineScheduler$Worker.executeTask(CoroutineScheduler.kt:750)
at kotlinx.coroutines.scheduling.CoroutineScheduler$Worker.runWorker(CoroutineScheduler.kt:678)
at kotlinx.coroutines.scheduling.CoroutineScheduler$Worker.run(CoroutineScheduler.kt:665)


You must be using an old Blokada version, updating the app should resolve the issue.

1 Like

The latest update I received was 66602240 (Blokada app downloaded it).
What is the latest one?

I’m just wondering why I got the api error only today.
The add blocking etc. is working just fine.

Also if I go to the version that is on google play, is that a free version like the one on your web page?

The latest version is Blokada 22.4.20, once you have this version the message “API request error” shouldn’t be appearing anymore

Hi, thanks from the info.
I don’t know what happened, but the API error is gone.

The only thing I can think of is the BitDefender antivirus definition files.
“Maybe” they released an update yesterday that broke something.

Is the 22.4.20 the one that is on the play store?

The Play Store version (which is Blokada 6) should be not getting this error. If you are on Blokada 5 (from our website), then you need to be on the latest (22.4.20). In general this error message is harmless.


I have the same API error. It is version 22.3.7 I tried to update it , but Blokada is not even available in the apps list. How to update to 22.4.20 ??

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Blokada 5 can be updated from our website https://blokada.org

You may need to uninstall your current version first.