Android Blokada 6 VPN can't select location anymore!

to make posting more easy, we created a guideline for you:
Please always include which platform you are on: Android or iOS. If you have a question about features feel welcome to ask it - if you face a problem, please follow this template:

Title: please select a meaningful title!
e.g. Blokada for Android doesn’t block ads in my-little-farm-animals app

To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from?
    Android store

  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using? Android 12 Samsung Galaxy phone

  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
    For some reason when I try to enable location it says my VPN is turned off. I’ve turned it on and it shows is there but it keeps defaulting to off see attached screenshot

  4. Since when are you facing this issue? Just today

  5. Did you already try to solve the issue somehow? If so: please state what you did.

I tried restarting phone, deleting VPN profile and re-adding it again and still nothing, can’t select a location anymore. My Blokada plus subscription is valid until next year and have set to automatic renewal each year on the android store.

I also did notice the Blokada UI changed today, it looks different so I’m under the impression there was a new update and somehow that might be the issue as to why I can’t connect to your VPN anymore. I tried a free trial of a different VPN on the android store and it worked fine and stayed On VPN just for testing purposes.

Unless there’s an issue I’m not aware of?

Update: for some reason I never bothered to look at my devices, but it was showing my phone in the list and was detecting my phone as a new device so I couldn’t add my phone because of the 5 device limit. Had to delete my phone and add it again and it’s working again, problem solved.


Same. Thank you for sharing this solution!
Hope the error message can be more clear in an update. Would have saved me quite some time trying to get Blokada working again (reboots, VPN profile deletes, stubborn keeping to click on the location button,…)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.