After update to android 13 with Nov security blokada dies

to make posting more easy, we created a guideline for you:
Please always include which platform you are on: Android or iOS. If you have a question about features feel welcome to ask it - if you face a problem, please follow this template:

Title: please select a meaningful title!
e.g. Blokada for Android doesn’t block ads in my-little-farm-animals app

To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from?

  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    OnePlus 9pro stock OS non root

  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
    Blokada app stops working and VPN indicator goes away after a few minutes of use

  4. Since when are you facing this issue?
    started with android 13 Nov update.

  5. Did you already try to solve the issue somehow? If so: please state what you did.
    uninstalled app, rebooted, reinstalled from blokada. enabled settings to allow keep alive and ping hosts, set android permissions on the app for background use , set app to ignore power savings, forced blokada to use it’s own DNS.

Hi there,

Have you tried activating always on VPN?

That setting was not activated. Let me try turning that on and I will report back.

I’ve had a similar issue that started somewhere around the Android 13 September or October update. First on Pixel 4XL and now on my brand new Pixel 7 Pro. I have always-on VPN configured, and occasionally (every few hours, maybe?) Blokada stops and I get a notification about the always-on VPN being turned off. It usually comes back on its own after a minute or two.

Occurred on Android 13 since September or October update (can’t remember) on Pixel 4 XL, and still occurring though seemingly less frequent on Pixel 7 Pro, December update.
I downloaded Blokada 5 v22.4.20 from but the issue has been around for the past 2-3 versions at least.

I tried clearing data and reinstalling on my P4XL which didn’t solve the issue, and I haven’t really tried any troubleshooting steps on my P7P yet since it was a fresh install on a new phone.

I am having exactly the same issue with a Pixel 4a . Blokada constantly “dies”. Usually starts with it getting unresponsive - the tile doesn’t show either active or inactive, just greyed out, Then everytime you try to turn it on, it just dies again.

“Always On” is set; and as others have posted, this started around the October.

Since it’s a fresh install, it’s probably because of your battery saving settings, try these steps:

I presume you tried all this right? If so please share log with me at

Making that setting change did not work. Let me review the information in that link to see if I can change the settings in my oneplus. I will post an update.

1 Like

Changing the battery settings made no difference for me either. Will provide log if/when it happens again

1 Like

Following the link provided by @Reda_Labdaoui
It looks like Android 13 had some new battery settings per app that needed to adjusted. After making the changes under the OnePlus my Blokada app is working as normal.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.