Android 12 permission request popup

Information


  • Plataform: Andoird 12.03.00 Compilation: 4.14.186
  • Default ROM from Motorola, i upgraded to android 12 recently and when re-installing the update I’m getting this
  • Mobile: Motorola G(60)s

Download from https://blokada.org/

The problem


When try active Blokada and when show popup with “Just one more step…” and i touch “continue” button. No show popup with request permission to private VPN

Did you already try to solve the issue somehow?


I have tried re-installing the application in several ways, and I have even tried other applications in case it was Blokada alone… But there is really nothing on the forum like it

I think it is a problem of Android 12 itself, I do not know why but not in other applications that require a VPN does not show me the popup to give permissions and I do not know why.

More information?


Logs: 04:10:36.028 E da.origin. Not starting debugger since process cannot load the jd - Pastebin.com

I don’t think I can provide any more information :sweat_smile:

Usually restarting device helps in such scenarios. Other than that make sure you use the newest app and remove any other Blokada versions you may have installed on this device.

1 Like

You can also try deleting any VPN profile from your device by going to settings → Connections → more connection settings → VPN.

Once you delete all the profiles, try activating Blokada again.

I have already tried it and nothing.
Completely re-installing, rebooting after installing and then testing. Nothing works for me

I have no VPN profile, literally the application has no permissions because I don’t get the popup to give it permissions.
After so much re-installing, clearing cache, cleaning data, uninstalling, installing… I would be surprised if there is some kind of VPN profile.

If you look at the log 694 line, you can see Requested to start tunnel, no VPN permissions, and line 706 line you can see VPN permission not granted, returned code 0.

But I never got the popup requiring permissions

I finally found the problem, it seems that the Motorola company decided to release an Android 12 without VPN option :man_facepalming:

Apparently someone managed to solve it with 2 applications “App Ops” and “Shizuku”.

Original post: English Community-Lenovo Community

1 Like

This is genuinely very amusing

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.