"'Please enable VPN permissions"

Galaxy Tab A - SM-P580
Android 8.1.0
Samsung Experience 9.5
Blokada 4.7.3

Getting a message to “Please enable VPN permissions” when trying to turn blokada on. It then turns itself off automatically.

Was able to use a previous version of Blokada on this device, but decided to update to the latest version via Blokada.org. I’m unsure what this message is referring to, but I checked the persmissions for Blokada in android settings, and there seems to be a checked box for storage. There is no entry for Blokada in VPN settings menu.

I configured it to run with AdGuard DNS and Energized Blu host list. Have not changed any settings other than defaults.

Hi,
This normally occurs after ROM updates.
Clear the cache of Blokada. It should ask you for vpn permissions again.

1 Like

That fixed it. Thank you very much! :slight_smile:

The first time I turned it on after that, it android prompted to allow the app permissions, and it seems to be working without issue now.

You’re welcome