After update the app is stuck on loading

Android 13 user here.

  1. Have Blokada from PlayStote, Plus Subscription.
  2. No Custom ROM, Motorola brand
  3. After last update (change of the layout etc.), the app is stuck on loading, but the circle never turns yellow. At the same time I cannot choose a VPN, because the option does not load up. I cannot change the cards below (settings, usage, blocklists).
  4. Since a week ago.
  5. Tried clear cache, clear memory, uninstall and reinstall, no change.

Thanks for reporting this, we’ll have to take a closer look into this.

Can you send over your log to

I’ll make sure to check it out and get back to you with a solution.

Thanks Reda, can you help me how to gather log?

FYI, I’ve noticed this on my Galaxy S21 Ultra, running Android 13. It happened quite often over the last few days, although ironically, is behaving itself just fine at the moment.

  1. Reproduce your problem

  2. Go to the app, tap the dots icon in top right

  3. Tap “Share log”

  4. Send the log to


We are looking into this issue as we speak. @Reda_Labdaoui will keep you updated on when it’s resolved.

You could try the steps suggested here as a work around:

Hey guys,

This issue has been solved with the latest release 23.4.35.

Can you please check and share your feedback?

@ViperGeek @Uuv

1 Like

Thanks Reda.

I have not seen this issue since upgrading to 23.4.35.