A certain app doesn't work if blockades is activee

Hi. I’m using blockada downloaded from official website on my Xiaomi mi A3 with Android 9 pie stock ROM.
Until some days ago all worked well. Now I have problems with app TIM Telefono in my device. This app is only for my country (Italy) and allow me to telephone with my smartphone using my telephone landline’s home when I’m connected to my wifi. If Blocckada is active Tim Telefono can’t allow me to receive and make calls with my telephone landline. I’have also tried to put this app in Whitelist and permit some hosts that seems are blocked from Blockada when I use this app, and in this way the app works but only until I disconnect from my WiFi, when I reconnect to my WiFi the app doesn’t work anymore, I must disconnect from blockada, reactivate TIM Telefono with an internal reactivation option and then reactivate blockada.
What can I do?


Hey there:)
did you reboot your device after bypassing the app in Blokada? If not, please try that and see whether this changes something.
Do I understand correctly, that this only happens after a network switch?

Yes, correct. This problem happens when I switch from wifi to mobile network and then again wifi. If I stay only in wifi TIM Telefono works well. And of course I’ve rebooted my device several times but nothing change.
Could be useful to post my hosts log? I really don’t understand what blocks this app.

1 Like

Okay, did you try to do the same with another VPN-based app, for example a real VPN or something like DNS66?
Did you try the same with Blokada disabled?
The thing is if that app is bypassed, there (i) won’t be anything shown in the host log from this app anymore, as the app is operating completely outside of the local VPN tunnel (so you don’t have to send the Host log for now) and (ii) the app shouldn’t be affected by Blokada at all. Except if the app depends on some service apps that are not bypassed in your System apps in Blokada. Did you change anything in the System apps menu? Could you maybe share a screenshot of the system app’s menu in Blokada?

I’ve tried also with another vpn-based app (Adguard) but there is the same identical problem. Maybe this is correct: TIM Telefono depends on some service apps that are not bypassed in my System apps in Blokada. But how can I discover what are these apps?

Okay. Then it’s no isolated Blokada problem, but probably depending on VPN.
In Blokada go to Apps / System apps. Tap bypass all apps. Then reboot your phone. !!!Note now you may see ads, but this is not relevant for now, as we can fix that later, but we just want to see whether it depends on another system app!!! Then try the app again. Does it work now?

Tried, all system apps setted like ignored in Blockada, rebooted the phone… But nothing is changed. Tim Telefono doesn’t work when I disconnect and then reconnect on my WiFi. If I completely disable blockad instead works. :frowning:

Then this is an issue with the usage of the VPN api and your Tim Telefono app. This means Blokada cannot change anything here unfortunately…:frowning:
But you could try to get this working with Tasker or a similar app:)

It only happens when I connect too the Montreal gateway. As soon as I switch to NY, it starts working. I switch to Montreal, it stops again.

Montreal seems to work with the IOS version on my ipad but not on my android phone

I have VPN Unlimited, Tunnelbear, Mozilla VPN, NordVPN and I can switch locations with any of them and they work fine.

This doesn’t seem related to the topic.
Please use your own post instead.

Is the issue solved by now?