Ubuntu wireguard blokada conf parsing error

Hi there!
On a PC running Ubuntu 20.04.2 LTS, I’m trying to use Wireguard to connect to Blokada Plus VPN :

  • Activated Blokada Plus service and then created and downloaded the Blokada conf file by using app.blokada.org
  • Installed Wireguard on the PC and started going through the Quick Start guide on www.wireguard.com/quickstart : cli interface, there’s no gui in the Ubuntu version.
  • First two steps ok, created a wg0 interface and assigned ip address.
  • Third step is to apply the conf file to the interface, but here there’s a parsing error, it doesn’t like the Address= line for some reason, see attached screen shot.
    Could you help, please? I’m not a network guy and don’t have a lot of time to delve into the cause…
    Also a question : If Ubuntu succeeds in using Wireguard + Blokada VPN, it’s going to loose the advantage of the Pi-hole DNS filter on my home network… Is there a way to have DNS filtering in the Blokada DNS service via VPN ?
    Thanks for your help!
    SeanWireguardConfParsingError
1 Like

Try checking for any updates by using

sudo apt update
sudo apt upgrade

or it may be because Linux works in a really weird way.

Thanks elburg for your advice. Upgraded 3 packages, but unfortunately the parsing error is still happening. The packages were libxnvctrl0, nvidia-prime and nvidia-settings, so probably not related to my problem.
Regarding my pi-hole question, I discovered there are several publicly available pi-hole dns servers, for example ahadns.com so that’s a possible solution once I get wireguard configured :slight_smile:

1 Like

Hi again,
Just to let you know Wireguard is now working fine on my Ubuntu. My error was to follow the Quick Start guide on the Wireguard site. In fact it’s simpler than that: you just copy the conf file that was generated by the Blokada app website to the /etc/wireguard/ directory, and rename the conf file to wg0.conf
Then you start the VPN tunnel with the command: wg-quick up wg0
To stop the tunnel: wg-quick down wg0

3 Likes

Oh yeah, forgot to say: I removed the ipv6 address from the conf file, that solved the parsing error. Probably not the right solution but…

It might have been the ipv6 address, as looking at it with the error message, it looks like a link local address and may not have been correct for your device or interface. (if I remembered that info correctly)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.