Something wrong with f-droid version

**Android **.

Blokada keeps disconnecting/connecting every second when downloaded from f-droid

  1. Where did you download Blokada from? F-droid
  2. Pixel 4XL stock ROM Android 10
  3. as soon as I activate Blokada, it starts disconnecting/connecting every second. Always on and other settings don’t change that behavior. Always on VPN makes my network disconnect every second. Wi-Fi + 4g
  4. Since when are you facing this issue? Since I installed Blokada today.
  5. Downloading blokada from the website solved the problem

Hi there, welcome to the forum!

Just to make it clear, did you download the same v4 as on F-droid or did you download v5 beta from

As soon as v5 comes out of beta, it will also be published to F-droid. We’re confident this fixes the disconnect issue you experienced

V4.7.3, I didn’t download the beta from the website.

Feel free to check out the beta. It should tackle the issue you’re facing

U just tried the bèta. No internet connection when bèta is active so reverted back to 4.

Did you disable Private DNS on your device? You can find it in your phone settings

That fixed it. Shouldn’t there be a pop-up that says ‘disable private dns to use blokada’?

We considered that in the past and still consider it.
Unluckily the Private DNS setting isn’t located in one specific spot. OEMs change its location all the time :confused:

It’s in the network settings. I’m optimistic that anyone installing blokada can find it :laughing: