Samsung - V5 Android works on wifi, not mobile

While on WiFi, I don’t have any problems. When I switch over to mobile, nothing loads at all, I usually end up with error pages stating such after a long timeout wait by whatever browser. As soon as I deactivate Blokada, everything is fine.

I had a similar issue when I first got V4, and I believe that was related to private DNS and made sure that was disabled.
I read a post about an issue with V4 not having DoH (ISP DNS settings conflicting or something), and have confirmed that is enabled, but I used V4 for quite a while without an issue and I have only had a problem since I reset my device and upgraded to V5.

To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from?
    The Blokada site
  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Note 8, default rom, Android 9
  3. Please explain possible**. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
    See above
  4. Since when are you facing this issue?
    This has been a problem since V5, I did not have the issue with V4.
  5. Did you already try to solve the issue somehow? If so: please state what you did.
    In V4 I had a similar problem. I checked my private DNS to confirm it was disabled.

Hello, have you tried disabling dns completely in v5 to see if blokada works?

If you continue to have issues, please send a log to with the device name, os, and a description of the problem.

Fyi there have been some problems with some Samsung devices with the August/September update. Check here for details (scroll down)

Hey there:)
did @Queen_Patience’s tips help you:)?

So after I sent the message, It hasn’t been as bad. I am going to attempt to send logs if it happens again.

Okay, well the problem lies in Samsung’s patches. It could be fixed with the September update. If it’s not, then please use the adb command, as explained in the post above:)
If that didn’t fix your problem, please report back!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.