Samsung "Mobile Data Only Apps" does not work

With running Blokada 5 (latest free version) I cannot use “Connections/Data Usage/Mobile Data Only Apps” on my Samsung Galaxy Note 9 (Android 10, OneUI-Version 2.5, latest Software Update). When I turn Blokada off, it works. Is there any trick to change this? Or does the pro Version of Blokada support this?

Do you have a solution?

Could you please describe what the functionality normally does? I’m not a Samsung user :slight_smile:

You can connect some apps only via mobile data, while the rest is connected via wifi. This is cool, because you can save mobile data with wifi e.g. for YouTube, but allow e.g. Clash Royale always a stable mobile connection.

Hello, have you updated to the latest v5 (v5.11) to see if it solves your problem? I have Samsung so I know which feature you’re talking about.

And just for clarification:

The adblocking function of blokada is free and will always be free. It works the same regardless of whether you have Blokada Plus or not. :slight_smile:

Unfortunately it’s still “greyed out”. The screenshot is german, because I am, but it shows the problem.

Hi Percy,

I just checked on my device (s10, Android 10) and I actually have the same issue. Deactivating blokada makes the feature available again. I wonder if it’s possible the feature uses the vpn api of the device…

I don’t use that feature, so I didn’t even know this problem existed. Why do you want some apps to only connect on mobile data?

Unfortunately I can’t think of a solution.

What you should do is send a log to with a detailed description of the problem (and also specify what device you have).

Fyi because this is Samsung specific and not a general Android error, I’m not sure what can be done.

One game I play, Clash Royale, needs a fast and stable connection, otherwise it freezes and I lose the matches. Other apps need much traffic, but the are not so demanding. Because I have only 3GB traffic per month, I always have to switch Wifi on and off manually. It would be very helpful to use this option.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.