Oukitel W6 and Blokada

Hi There, total newbie having discovered that Android 9 on my Oukitel W6 breaks Adguard. So far, totally blown away by the quality of this app - thank you.
So far, I’d say that Blokada stays running about 95% of the time. Though even with the “stay live” feature and all Android 9’s ridiculous power management feature configured, supposedly “ignoring” chosen apps, it still manages to shut the app down occasionally. With VPN always on set it is a simple toggle on the home screen, it’s back. It’s a shame, dunno if there is any other way around it?? Also, the app will not “autostart” on android 9
One other thing, I hid the Stay live notification in the drop down menu…is there any way to unhide it please??

Thanks all…awesome app

SimonC

Hi Simon,

Welcome to blokada! I see you have tried some of the troubleshooting steps (excluding blokada from battery optimization, turning keep alive on)-here are more to check:

  1. If you have a dns on in blokada disable it-this is to ensure that the problem is not associated with the dns.

  2. Have you turned off Private DNS in your phone settings? If not please make sure it is set to off.

  3. In your phone settings set blokada as the always on vpn (as well as having it on within the blokada app itself).

To solve the autostart issue, have you rebooted your phone after selecting "always on "vpn in blokada? That typically works- blokada has had some issues with starting on boot in android pie.

Hmm u want to unhide the keep alive notification? Usually people want to do the opposite XD. To change the notification from silent to alert varies on each phone. On my phone you hold down the notification to change its alert settings-maybe that will work for yours.

Please report back and let us know if this works for you :slight_smile:

Hi Elizabeth,

Thank you so much for taking the time to respond to me.

I have now carried out all your suggestions and will report back :blush: Just one question, if your suggestions work for me, should I keep DNS off permanently?

Thanks

SimonC

Private DNS needs to be switched off at all times.
You may set a dns of your choice within Blokada though.

1 Like

Hi There

Thanks for the feedback.

I’ve done all the suggestions from Elizabeth & yourself, and Blokada for the most part works, but still has random shut downs, with no particular pattern. It shows the “always on VPN is disconnected” symbol in notifications, and I have restart Blokada….It’s a pain :frowning:

Any further suggestions?

Thanks

SimonC

Look through this website: dontkillmyapp.com

Thanks for that mate…Just an update, installed on my Honor View 10, and it runs flawless…Still no joy on my Oukitel, but I have been testing some settings, and tweaking the battery settings on & off, and I have come to the following conclusion. Oukitel’s interpretation of Android 9 is broken. Or at least the battery tweaking part of it. I’ve found that whether I set power management to ignore apps or not. the system still kills the app sooner or later. I’ve also found that whether I turn “optimizations” on or off, it make absolutely no difference to the apps in question…Very frustrating. The irony of this is that the W6 has a monster 10.000 MAH battery, so I don’t need bloody optimization at all, lol.

Thanks

SimonC

Sad
But extremely funny at the same time

Lol, I’ll give you that, currently giving Version 3.4 go :slight_smile:

That’s… Very, very old

Well, if it works…and stays working

I’m now up to version 4.6…this version has “agressive wakeup” along with stay alive??..Do we know why this was removed??

Thanks

SimonC

These features aren’t necessary anymore. They were sort of workarounds for older android versions.

Really? the explanation of it’s use says it due to Androids Powersave feature…gonna stick with it to test the water…It could be the answer for me??

Shouldn’t be a solution but if it is: Let me know
Powersaving has been a part of android for a long time now.
The beginnings were pretty rudimentary. That’s what this option addressed. New android power saving solutions are much more sophisticated.

I will do pal…After updating in app, I’m on 4.3.5…I’ll stick at this, and let you know. The power-saving & battery management features have become much more aggressive in Android 9 & 10, maybe that could be it…at least for me anyhow…what build was the “aggressive restart” feature removed ??

Thanks

SimonC

Iirc with the introduction of v4
You can’t see it since then

Sorry for being dumb? I’m on v4, which build was it removed from?..just so I can have the latest of that build :slight_smile:

Thanks

SimonC

V3. 7 should still have it

Cheers m8, I have weird things to report. Firstly after trawling the net for different versions, and trying nearly all of them I can confirm that “aggressive restart” was present until version 4.4.2. The versions with aggressive restart ran almost flawlessly with the notification disappearing twice, but the app appearing to be still running. Now here’s the weird thing. all my installations have been “upgrades” as opposed to clean installs which my first experience with the latest version of the app. I have now upgraded to the latest version from within the app…and so far it has run flawlessly…Fingers crossed :slight_smile:

Thanks

SimonC