Frequent access denied issues

Continuing my question from discord here, since I think you guys are not that active and I absolutely can understand that so no problem.

  1. Where did you download Blokada from?

I get my Blokada 6 directly from the Google Play Store, and I paid my subscription also directly from it.

  1. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?

I used Sony XZ2 with the default Android 10 that came from the box.

  1. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.

For information, I ran my Blokada both on Android and Mac (through WireGuard). I used the Singapore server as its the closest to me and used Cloudflare as the DNS (only for the WireGuard setup on my Mac since was asked to choose one, unlike the Android which asked for none).
There is no particular order of steps thats leading to the issue, its just straight up showing ‘Access denied’ or always make me go through a captcha identification because its always detected me as a robot/spam when I absolutely not. Example shown in the screenshot below:

This one is from, which at first working just fine. But when I tried to login, it led me to this ‘Access denied’ page and left me stucked in there. Another example below:
This one is from, which sometimes worked just fine but almost all the time sent me to this captcha identification first because apparently my action was automated (?) which was not.
There are some other websites as well which does this, including discord & anything related with it, but mostly sites that uses Cloudflare services (from seeing the ‘… by Cloudflare’ on its ‘Access denied’ page).

  1. Since when are you facing this issue?

I think its started sometime around the end of last year (based on the last time i can access from my browser history is on Nov 2022) and its been going on till the time I make this query.

  1. Did you already try to solve the issue somehow? If so: please state what you did.

I have tried several attempts to solve it my way and that is:

  • Trying to change the DNS for my WireGuard config to every option available at (didn’t work)
  • Trying to change my Blokada server to every option available (didn’t work)
  • Restarting my devices (didn’t work)
  • Changing my net provider, already used/change between 3 net providers every month since November, December, and recently on January (didn’t work)
  • Changing from wifi to cell data (didn’t work)
  • Trying with other device (Samsung A52s 5G) by using my Blokada ID (didn’t work)

Please help cs its been happening for months, and I’m starting to lose faith on continuing my Blokada subscription but I already billed for this month so I’m giving this February as my last judge whether the issue still persist or I will move on.
I wish you guys all good luck on solving the issue, its been great using Blokada except for when this issue slapped me in the face. I hope this resolves soon and I will absolutely wait for when you guys get back to me with a good news. Thanks.


We will reach out to these service providers to see if there’s anything we can do to avoid getting blocked like this.
In the meantime, you could try using Amsterdam or Stockholm which are from a different ISP than Singapore.

Sorry for the trouble, we will continue expanding our gateway network with different ISPs in the future.

If you experience any issues at all with Blokada Plus, don’t hesitate to reach out directly on instead of first going through our social channels


I just tried switching again to the Amsterdam server. At first it didn’t work like before, but after i cleaned my browsing data NOW ITS WORKING!! So thanks a lot for the quick response.

Then again since Amsterdam is quite far away unlike Singapore which is the closest to me, I got quite a spike in my pings than what I got regularly from using Singapore. I can see some lag when I used streaming services like on, but I’ll take that for now cs its better than having a frequent ‘Access denied’ like before.

Can you guys give me a heads up when the Singapore server issue resolved? I’d love to get any info on that whenever possible, instead of constantly switching to the Singapore server time after time just to check whether its resolved or not by myself.

Thank you again for the fast response and I hope you guys all good luck resolving the Singapore issue. God bless.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.