DNS encryption doesn't work, slow internet, all on Android 11

  1. Fdroid version (play store version is practicallythe same so it doesn’t matter). Be it 5.9, 5.10 or 5.10.1 (I guess) none worked.

  2. Samsung Galaxy M31, stock ROm, non root, Android 11, UI 3.1

It was resolved in latest version for many but Android 11 was left aside.

Also, we are requesting firewall since a very long time. This is a very simple feature that should be provided with blokada. Some apps don’t deserve internet at all.

Unluckily it’s not that easy to implement it.
That takes time and effort.
Feel free to contribute to the project yourself our Sourcecode is public. If you manage to implement a firewall feature we’re going to credit this of course

Just wanted to say that I don’t seem to have the slow internet problem even though I’m on Android 11 as well.
Maybe it’s the DNS? I use “Digitale Gesellschaft” with encryption.

My phone: Xiaomi Mi Note 10 Lite, Android 11, MIUI 12.1.1

Any of the DDoS?

Not sure what you mean… Distributed Denial of Service!?

Yes that happens in DoT and not DoH

DoH DNSs are
Blokada DNS
Google DNS
Cloudflare DNS

Have you tried any of these encrypted?

Then try opening a media heavy website
Like youtube
Or mmm any site that offers videos at home page like some NSFW (you know what I mean)

Ah yes, when I switch to Blokada DNS then internet is unusable. Can’t even get to my local newspaper website (sueddeutsche.de). It’s not getting resolved at all.

Cloudflare DNS seems to work though…

Switched back to “Digitale Gesellschaft” again. Been using that for a while and so far no issues.

That’s strange

Blokada dns doesn’t work at all even without encryption. That is another matter.
Ignore blokada

I’m talking about cloudflare and Google only

DoH (without cross over LOCK)

Both don’t work with encryption turned on.

They only work with encryption off. Android 11.1, Samsung galaxy m31.

Cloudflare worked for you on encryption is strange to me though.

I want to use DoH DNS only. But with encryption. That’s not happening for me.

Can we make a separate app and use it using your source code?

Yes, Cloudflare with encryption works fine. And the “Digitale Gesellschaft” DNS is also encrypted.

Maybe it’s a regional issue depending on what server the DNS service routes you to!?

Then everything is working for you (blokada dns is not an issue it could be down temporarily). Your dns too didn’t work for me.
Using unencrypted dns now.

Very strange… Sadly I’m out of ideas now, other than trying with a different phone :grimacing:

Hopefully the devs will figure it out soon for you.

Hmm idk. Fixing that ain’t broken is sometimes messy. Blokada 4 was great, UI was much better and also if UI is a personal preference, even then this ui is buggy with BACK BUTTON command. Doesn’t exit straightaway, keeps on doing loops. I guess I’ll use 4 for sometime as it is still supported unless this new version becomes stable. Thanks and good bye

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.