DNS configuration ignored on wifi

I have Blokada 5.18 for Android and ever time I go onto my wifi network it ignores my DNS preferences and tries to use DoH instead.

Under network settings I have specified “Cloudflare: malware & adult blocking” for my wifi network, my mobile network, “any mobile network” and “any wifi network”. I’ve also specified “prefer network DNS” for my wifi network, which should make it use a local resolver.

On connecting to my wifi network Blokada keeps trying to use DoH. I have blocked on my network so this doesn’t work. If I force stop Blokada and then restart it, it works correctly.

Is this a bug or is it possible I’ve misconfigured it somehow?


  1. Where did you download Blokada from?

  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
    Android 10 on Moto G9 Plus.

  3. Since when are you facing this issue?
    For a long time.

  4. Did you already try to solve the issue somehow? If so: please state what you did.
    Adding config for all networks, changed the Ping networks setting