Cannot Access Internet When Blokada 4.8.4's Custom DNS Setting is Active on Android Phone with T-Mobile Wireless Data Connection


I am using Blokada 4.8.4 on a Sprint Samsung Galaxy Note 20 Ultra 5G with stock Android 10 and One UI 2.5. I downloaded the Blokada app from

Prior to Sprint merging its network with T-Mobile’s wireless infrastructure, I was able to use Blokada’s inbuilt DNS switcher without any issues, as Sprint’s network utilizes ipv4 and Blokada’s DNS switcher only utilizes ip4 DNS. However, in my local area, newer Sprint phones are fully integrated into T-Mobile’s wireless network, which only uses ipv6 over wireless data connections. This makes Blokada’s DNS switcher incompatible with T-Mobile’s wireless network because it uses ipv4 DNS, while T-Mobile’s wireless network uses ipv6 exclusively. Hence, I am no longer able to activate Cloudflare DNS in the Blokada app without it completely breaking my wireless data connection and making it impossible to connect to the internet. When I use Blokada with only ad blocking enabled, my wireless data connection functions properly, but as soon as I enable any alternative DNS in Blokada, my wireless data connection is disrupted.

I tried to solve the aforementioned issue by using a custom DNS in Blokada, specifically “2606:4700:4700::1001” which is Cloudflare’s ipv6 address, but the Blokada app responds with something along the lines of “That doesn’t look like an ipv4 address,” and it doesn’t allow me to enter the ipv6 address.

I wanted to know if this issue stemmed from Cloudflare directly, so I disabled Blokada and downloaded Cloudflare’s “” app from the Google Play Store and activated its VPN connection on my phone. It successfully connected my phone to Cloudflare over my wireless data connection without any issues. Unfortunately, however, I obviously cannot use both the “” app and Blokada app simultaneously, as I can only have one VPN connection active at a time.

May the Blokada development team please add support for switching to a private DNS provider by using the provider’s ipv6 address? Or specifically remedy the issue of Android phones on the T-Mobile network not being able to use Blokada’s DNS switcher without breaking their wireless data connections?

Being able to use Blokada’s ad blocking and private DNS settings simultaneously is important to me as someone who values his privacy. May someone please help me to resolve this issue?

Hey there and welcome to the community:)
in version 5 of Blokada you can select to allow ipv6 as well. And you can use DoH servers in v5. Maybe this will fix your problem?
But before upgrading, please check the Blokada: Changelog whether all features you are currently using are already ported to v5. If you set manually blocked / allowed hosts my advice is to screenshot them, currently they are not being restored after the update to v5.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.