Blokada notifications are not able to be enabled

I am on android and just found out today that Blokada wasn’t doing anything due to the ability to enable notifications with the app being disabled. “All notifications from this app are blocked”. I scoured my phone settings and internet for any clues and nobody else has brought this up. Am i just screwed? I’ve been using Blokada for over a year now and now it just doesn’t work because I can’t bypass a setting!

Any help would be appreciated.


I’m having the same issue on 2 of my devices today too. It started after I installed a Blokada update from the playstore

1 Like

Yep, same thing happened to me. No solution found

1 Like

Hi all,

We’ll be releasing a new version soon that will resolve this issue.

Thanks for your reports it helped solve this.

1 Like

Any update on when this update to fix the update will be released? Heading into day six of not being able to utilize the service.

1 Like

There is already an “update” available on Play Store rolling back the new features which cause this problem.

1 Like

Hmm. My play store still shows the Sept 29 update as the current one and I dont see an option to download the prior

1 Like

This should be the version fixing the issue. Version number is 23.3.8.

1 Like

I have that same version on my Android 12 and I don’t see the notification either.

This appears to be an ongoing issue with diff devices so if it worked for you, it definitely didn’t work for me because I have the same version and notification icon is gone perhaps they are still testing tweaking the update.

Then the change causing this issue must have been introduced earlier.

Same here - I’m just in the process of configuring my new Android 13 device; downloaded the app early yesterday, tried to activate my “Plus” account, notifications were greyed out.

Suspecting a problem with yesterday’s installation, I uninstalled/reinstalled.

No change.

Blokada seems to be sort of working, though, because in the brief time between dismissing the “nearly there” message and its reappearance, I was informed that the app had dealt with 3000+ ads and trackers.

Day 14 of not being able to use this paid service. Day 8 of a “coming update to fix the update”

I’m having the exact same issue & the Blokada Discord is seemingly a ghost town? What’s up with that?

Hello everyone,

Just wanted to jump in and acknowledge the notifications issue many of you have reported with Blokada 6 on Google Play. We’re taking this seriously and actively working on a fix.

Once we’ve confirmed the issue is resolved, feel free to reach out to our support team via the in-app help for compensation. Thanks for bearing with us during this time.

Hey everyone,

I’d like to share a quick update.

Yesterday, we introduced a new release (22.3.9) to Google and it was approved.

It solved the notification issue and would love to hear your feedback once you test it out.

Just installed Blokada 6 Cloud, (Plus,) v24.3.2 Have not yet tested activating.

Need to check both Notifications issue and periodic loss of internet connectivity until rebooting.

Pixel 6a, Android 14, Blokada 6 update 17 Oct 2023 from Play Store.

[Comments can be moved to Internal if needed.]

Blokada Talk minor bug:
One unread topic link opens a post from bugtracker KnowledgeBase of No unread topics then line with Dismiss in small font.

[Fixed my typos]

1 Like

17 Oct 2023: After today’s [Internal] update from Play Store Blokada 6 Cloud (Plus) displays Purchase Subscriptions page. Pixel 6a Android 14 vanilla Metro by T-Mobile ROM.

Restore Purchase now works seamlessly. Green Cloud activation button appears but with outermost ring continuing to circle animation. [Circle I] must be clicked to reveal Activation is waiting for Notifications Permissions approval.

Click Allow Permissions and activation completes automatically moving the slider button. Cloud Plus fully activated although with notice that Logging is not required.

For test purposes I turned Logging on and can see traffic logs! So far my major issues with Blokada 6 Cloud Plus are fixed with today’s [Internal] build.

Have not yet checked additional Blocklists, About for version number, or other items noted earlier today. Great progress! I’ll continue testing on live Private WiFi with Cloud Plus active and add to this Talk thread.

1 Like

17 Oct 2023. So far browsing on Pixel 6a Android 14, vanilla Metro by T-Mobile ROM, Blokada 6 Cloud Plus subscription from Play Store after Restore Purchase then quick clicks on [circle i] Information for Notifications Allow Permissions. Update continues to work well and subjectively faster and smoother using Chrome Android browser.

[Internal] After Restore Purchase an explanatory note should explicitly mention to try clicking the [circle i] information symbol to enable missing Permission that needs to be accepted. Obviously my suggestion needs to be written in simple English (or default Language localization.

Solid green Blokada 6 Cloud button appears stable and running smoothly on Android 14 for browsing major web news sites, GMail, and Blokada Talk.

1 Like

I can confirm the .9 update returned the notification for me. Thanks for this!

Taking notes @Auldjohn , thanks for your suggestions