Blokada cloud provided hostname doesn't work

1 Downloaded Bookada Cloud from play market
2. Pixel 4a (5g) , android 13 beta

When trying to activate DNS profile, hostname Blokada gives me includes brackets (, which can’t be put as a name of valid DNS server. Brackets proabably appear becasue my device name had brackets in them, however changing device name doesn’t solve this problem. Can anyone please help?

Android Cloud is working fine on my Android Lenovo tablet but I can’t save the copied private DNS to my Android Moto G7 Power phone. . Surely it can be used on more than one device???

1 Like

I did the copy and paste and made sure my account number was the same as my tablet but “Save” is still greyed out. I am out of ideas!

I can paste the copied private DNS but still unable to save it. Save continues to remain greyed out. Uninstalled and reinstalled the app but still no save. Still defaults to the “Almost There” page when I attemp to enable. Everything installed perfectly on my tablet.

I would need the log to tackle this issue.

Please do the following steps:

  1. Reproduce your problem

  2. Go to the app, tap the dots icon in the top right

  3. Tap “Share log”

  4. Send the log to hello@blokada.org

Thanks!

Sent! Thanks.

Same here with moto g power. The dns profile is copied but the cloud app says it isn’t and won’t let me continue setup. Ok. I was able to save by removing the parentheses around the year in my device name in the DNS profile link, but it still will not complete the setup. Still says to “Activate DNS Profile” even though the hostname is pasted (with the parentheses removed) in the private DNS.
And blocker test shows 99% blocked, so it is working, but app will not connect to the blokada vpn.
Does it matter if we change the name of the device in the first part of the DNS profile link?
Android 11.
Log emailed

I also tried several modifications to no avail. If this cant be resolved, I will likely give up and go back to. Blokada 5. I did send in a copy of my log so perhaps the issue can be resolved by the tech wizards!

Hi,
The modifications do matter.
Blokada cloud needs the exact preset it gave you to recognise the device properly on the app.
Brackets is something we didn’t think of and didn’t come across in our beta tests with our beta testing users.
Stay tuned :slight_smile:

As a first step you could try changing your device name in your phone settings, reboot the device and reinstall blokada cloud

I tried changing device name, uninstall and reinstalling the app, deleting the cache, storage data, even all together. Non of this works, it still give me a hostname with brackets (same hostname it gave me on the first try)

Tried. My device name has no brackets - Blokada changes the device name and inserts brackets.

We’re currently looking into this.
Thanks for the logs
V6.0.3 is in Google review for a few days now and will be rolled out as soon as possible

2 Likes

The new cloud app update fixed it! Well done. All good on Android now.

2 Likes