Blokada 6 Private DNS issue

Blokada 6 for Android 13 frequently gives no connectivity error

  1. Downloaded Blokada 6 from Play store
  2. Device: Pixel 6 on Android 13
  3. I have been facing this issue ever since I downloaded Blokada 6. Never had the issue on previous versions . I have a subscription active. When I’m connected to my cellular data, I frequently get the no internet connection error. I have narrowed down the issue to the private DNS issue. As per the app, i needed to go into the settings and type in the dns "’. It usually gets resolved by itself but when the issue pops up, it takes about half hour or more for it to get resolved. I have tried reinstalling the app after removing it which temporarily fixes the issue. Tried disabling the location in the app, clearing cache and the data as well. Not sure if it’s a widespread issue. I know that it isn’t device specific since the issue popped up in my previous device (Xiaomi 10 running Android 12). During the issue, I’m not able to access the internet. Even disabling blokada completely doesn’t do tha trick. Below is the screenshot for a reference


Please don’t share your account specific information on a public forum.
To help you with the issue, please contact and we’ll continue there.

Include your geographic location and possibly your IP so that we can troubleshoot any connectivity issues for your location.
Find your IP on

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.