Blokada 6 on IOS blocks voicemail notifications and access

iPhone 12 IOS 16.4.1 (a) on T-Mobile.

When Blokada is selected as the DNS provider, new voice mail notifications are not received. In addition, the list of voicemail messages is not updated to show these messages.

This issue remains WHEN BLOKADA IS DISABLED via the app. Changing the block list does not resolve issue… neither does hard restart of iPhone. Issue is not affected by using cellular vs Wi-Fi or vice-versa.

Only way to resolve is to disable Blokada in iOS settings.

Issue was introduced after 1/6/2023 based on last voicemail that came thru while Blokada was enabled.

When I allowed only Apple apps to use cellular, Blokada Activity logging does NOT show anything being blocked.

I turned on Apple’s privacy reporting anbd it show Phone app accesses the domain “”. Blokada reports it is allowing this host.

I’ve been subscribed for over a year and greatly appreciate the service you provide. voicemail however is mission critical and if issue not resolve I’ll have to do without Blokada.


I’m sorry to hear about the issue you’re experiencing with voicemail notifications while using Blokada. It’s unusual as changing your DNS provider shouldn’t have a direct impact on your voicemail services.

When you disable Blokada from the app (while not changing the DNS profile), it could help if you wait for at least 10 minutes before testing again. This should be enough time for any previously blocked DNS entries in cache to reset.

As part of the troubleshooting process, it might be worth trying out other third-party DNS settings like Google or Cloudflare to see if the problem persists. You can easily find a collection of DNS profiles here. Just choose any of the HTTPS options, open it on your iPhone, and then activate it in your settings.

I hope these steps will shine some light on your issue. Please keep me updated with your progress!

1 Like

So I installed a competitors’ sDNS based ad blocker and tested for issue. Same problem.
Then installed the Google sDNS profile which has no ad blocking…
…waited… restarted…had wife leave me a voicemail…
…and duplicated the issue!!

So it’s not a Blokada issue. But 1) no idea if Apple or Tmobile issue 2) no ideas on how to get it resolved 2) still can’t use Blokada.


Given your observations, the issue might be related to how T-Mobile handles their DNS resolution. Some carriers do what’s called “split horizon” DNS, where certain DNS entries only exist within their internal network. Changing to an external DNS might be causing issues accessing these internal entries.

I would recommend contacting T-Mobile’s customer service for assistance, as they may have insights into this issue, or perhaps they have updated network settings that you can install.

Appreciate your efforts in troubleshooting, keep us updated on your progress. Who knows, perhaps the next voicemail message your wife leaves will provide the breakthrough we need in debugging :wink:

Is there a way in blokada to exclude the following domain from going thru its dns and go thru default instead?

Based on discussion Reddit - Dive into anything

Thank you for providing a potential solution. Based on your findings, I’ve added a new experimental option, however it requires the use of our web app instead of the native app. Here’s what you need to do:

  1. Navigate to our web app at
  2. Log in using your account ID. You can find this in the native app under Settings → My Account.
  3. Once logged in, navigate to the menu Blokada Cloud → Setup.
  4. Choose your device as iOS, then select the iOS profile alternative.
  5. You’ll see an option “Exclude problematic domains”. Select this and then download the profile.

Please give this a try and let us know if it resolves the issue. If it does, we can plan for including this feature in a future update to the native app.

Thanks a lot for your valuable feedback that helps us continually improve our service!

1 Like

It worked!! I set it up at 5am and the message my wife sent me at 8am came thru - both notification and the voicemail in phone up. Thank you for offering a path to solution. Please let me know once incorporate into the app.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.