Blokada 6 connection "freeze" when switching networks

Hey,

1. Where did you download Blokada from?
From the App Store.

2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
iOS 15.1, iPhone 11 Pro.

3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
I noticed a couple of times this week that my Blokada Plus connection basically freezes when I’m switching from LTE to Wi-Fi. I think it’s not always happening (I didn’t check everytime) but this is really annoying. This is how it happens :

I’m switching from LTE to wi-fi.
I notice I have no internet connection anymore.
I open the app and it’s not responding for a couple of seconds, just showing me the “on” button of the main screen inactive with a “please wait” message below it.
When the app is responding again, the button stays as it is : white and inactive. I can’t tap it, it’s not doing anything but I can switch from a menu to another.
About a minute later, everything comes back to normal.

However, today, the connection never came back on no matter how many times I was killing the app with multitasking.
I had to reboot my iPhone to get everything back to normal.
When the iPhone rebooted, I got my connection back but my lists weren’t active anymore. I had to activate them manually, just like the first time I launched the app.

4. Since when are you facing this issue?
Basically since version 6.0. I had some issues when switching networks before though.

5. Did you already try to solve the issue somehow? If so: please state what you did.
Yup, I downloaded a Wireguard profile and am using the Wireguard official app for now. Never had a single issue with it in the past so I consider it to be a more stable option.

Thanks !

Hello,

With Blokada deactivated, could you try downlading the tool from Hurricane Electric:

Then both with and without your WiFi activated:

  • Hamburger menu → Ping
    • IP Address: 2606:4700:4700::1111
    • Protocol: IPv6
    • Go

Let me know if you get any packet loss in the ping stats.

If you don’t get any loss. Could you please send us the log right after the issue has occured?

Hey,

Thanks for your answer.

Here is my HE.NET Wi-fi report :

And with wi-fi deactivated :

Every test has been done without Blokada.

I’m sending you the logs by e-mail right now.

1 Like