Android Auto on Android 14 (OneUI 6) and Blokada 6 Cloud from Playstore not working together


I am using a Galaxy S23 Ultra with OneUI 6.0 (based on Android 14) with Blokada Cloud (Blokada 6 from the Google Play Store) along with wireless Android Auto. Blokada blocks the Wifi connection that wireless Android Auto requires in order to function, and there is no way to whitelist the application like there was in Blokada 5. The only way I have been able to make it work is to remember to disable Blokada when I get into the car and re-enable it when I get out. This is less than optimal.

Is there something I am missing? Any help would be appreciated.

Best Regards,

1 Like

Hey @TheGatzBee ,

Thanks for posting about this, it is a common issue that happens with Android Auto.

The solution is to bypass Android Auto from adblocking and since Blokada 6 doesn’t offer app whitelisting, I’d like to suggest the following steps:

  1. Open Blokada
  2. Go to the Activity tab
  3. Click on this icon in the top right
  4. Copy this entry “”
  5. Paste it in the allowed section and click on Allow

This should solve the issue but please let me know if it doesn’t.

This didn’t solve it, still blokada is still preventing Android Auto from connecting

Hey @TheGatzBee ,

It seems like the team is already aware of this issue and is already working to solve it!

We currently working on implementing a workaround on app bypass in Blokada 6, in the meantime, if using Android Auto is necessary for your usage, I’d like to suggest that you use Blokada 5 temporarily while we’re resolving this issue.

Blokada 5 allows you to bypass system apps like Android Auto which will allow you to connect it to your car while keeping the VPN on.

I’ll also share a few updates here once I hear back from the team about implementing the bypass feature in Blokada 6.

Unfortunately until this is resolved I’m not going to be renewing my subscription. I love Blokada but this is a deal breaker :frowning:

Any chance this has been remedied or a workaround has been found? NordVPN is able to support this, as is GoogleOne … Come on guys I wanna use Blokada :frowning:

Hello @TheGatzBee,

Thank you for the feedback.

I wanted to check if you’re using Blokada Cloud only or are also using Blokada Plus with the VPN connected? Or any 3rd party VPN for that matter.

I only use one VPN at a time, I was using Blokada cloud with the VPN. I am also a user of NordVPN, for my laptop, but since Blokada wasn’t working with Android Auto I installed NordVPN on my phone as well.

To be absolutely crystal clear, when I was using Blokada and having issues with Android Auto it was the only VPN installed and active on my device.

NordVPN has split tunnel settings that work on an app by app basis however.

Best Regards,

Hi @TheGatzBee ,

I’d like to suggest a workaround using the Wireguard app while we’re working on fixing this issue.

Here’s how you can use it:

  1. Install the Wireguard App
  2. On your mobile device, go to → VPN devices → New Device
  3. Select your preferred VPN location and name your device
  4. Confirm and download the configuration
  5. Open the Wireguard app
  6. Click on the (+) in the bottom right
  7. Click on “Import from file or archive”
  8. Select your configuration and confirm
  9. Click On the configuration then on the editing pen in the top right
  10. Click on " All Applications"
  11. Exclude Android Auto

This should solve the issue temporarily while we get this fixed.

Please let me know if you need further assistance on setting this workaround up.

1 Like

This doesn’t do anything to help with ad blocking, does it?

The adblocking performance will remain the same, this will only help with the app whitelisting.