RunTime Crash: Unexpectedly found nil while unwrapping an Optional value

Hi All,
I have a latest clone and I was able to successfully build iOS build with some effort.
Now as a next step when run(hit xcode Play button) I get

am I missing something before I ran the app?

Thank you,

I can see “appios” suffix in that identifier. We have “app” in our source. Was it changed?

If you changed it you’ll need to also update other places. Try git grep, I think this place matters: IOS/Assets/IOS.entitlements:13

Thank you Karol. I am new to iOS development. I tried what you suggested and changed it in other places. With these mods I ran the build on my iPad Pro. its loads fine. but when I hit “activate” it complains about not being able to install/activate VPN settings.
My suspicion is that the iOS is perhaps blocking this app access to certain config since its not from official store(?)… Is that the case?
What else do I need to fully run the app built.


I believe you need to enroll to the Apple developer program (and pay the yearly fee) for accessing network extensions APIs