LG - Blokada works OK on cellular data, but cannot resolve any addresses using WiFi


Today I appled the latest OS update (Android V10b-AUS-XX) to my LG Velvet 5G (LM-G900EM). Previously I was using Blokada with no issues on both WiFi and cellular data connection.

Using either V4.8.3 or V5.0.9 the cellular data connection works as before, all web addresses seem to be reachable, e.g. WillyWeather app and DuckDuckGo browser. However if I turn on Blokada when using WiFi I can’t reach any web addresses. (Name not resolved.) As well as turning off Blokada I need to turn the WiFi off and on again before I can reach the WWW using WiFi.

Is there anything I can try to make this work?



1 Like

Hello, welcome to the Blokada community!

Have you tried multiple WiFi spots or only the one at home?
If you only tried one, my best guess is that your ISP are blocking you from using other DNS servers than the ones owned by them.

If this is the case, it should be solved in a soon to be released v5 beta update

1 Like

Try changing your DNS mate…i just checked mine and it works ok.

1 Like

Thank you for the suggestion, but I think this is internal to the phone as it was not a problem before the OS update. It is a home WiFi network. I have other devices connected to the same WiFi that use OpenDNS with no issues, whereas my phone is using the DNS of my internet provider when using WiFi.
I’ll do some more research, and also hope that a newer version might be better.

Try changing your DNS mate…i just checked mine and it works ok.

I’m looking into this. I’ve just discovered there are settings I wasn’t aware of in this phone. Thank you for the suggestion.

I’m seeing similar issues on my lg velvet (LM-G900VM). Works as expected on cellular, doesn’t allow any traffic on WiFi. New phone for me, so I don’t know if it worked prior to OS updates.

I haven’t found a way to get Blokada working on the WiFi connection, so I’ll have to abandon it and just use adguard’s dns for now.

Sorry to hear that. Don’t forget to share logs so that we might be able to fix this issue in a future update:

Thank you for the reply. I have sent the log as per your guide.


Hey there:)
did anything change for you with the recent updates:)?

I’m still having the issue on v5.1.0.

1 Like

Okay, let’s check some things then:

  • is there maybe a setting called something like ‘traffic mode’ in your system’s wifi settings? (Or anything else that could be relevant for this problem?)
  • are you able to access Telegram or another app that communicates via DNS requests while being on WiFi?
  • did you try to use another VPN service / an app that uses the VPN api and are there similar problems?

Private Internet Access VPN seems to have the same issue, so I’m guessing LG screwed something up with the last OS update.

1 Like

Okay, thank you for this information!
We noticed a similar bug with Samsung. They fixed it with the September update. Did you get an update from LG for September already:)?

It’s still in the August security update. LG is usually slow with the updates. So there’s hope the next update will fix it.


Okay, let’s hope that!
Could you maybe keep us posted on this:)?

Will do.

1 Like

This issue seems to be resolved now with the latest phone update. Blokada is working as intended with WiFi turned on.

LG Velvet software version: G900VM10e
Android security patch level: Sept. 1, 2020

1 Like

Thank you very much for the update:)