Ads slipping through after a few minutes


For a week or two, video ads have started to slip through the Blokada filter. Usually it works fine for a minute when restarting an app, but then it starts loading new ads from multiple blocked providers (Vungle, Unity, AppLovin etc). I see Blokada lists the related requests as blocked and I can’t find any other domains likely to be the source.

I’ve tried to reinstall the Blokada app, affected apps, turning on and off everything I can, but nothing works. I’m on iOS 14.5. Any ideas?

Not sure if this is possible, but would be interesting to get full request URLs in the activity section to better sort out the “sinners”. Like, a video ad is most likely an mp4 file, where did it come from?

Please try activating the Energized blocklist (Blu config). It’s in Advanced tab.

Both Energized (Blu) and Goodbye Ads (Standard) are activated. Worked smoothly since November, these issues began recently.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Indeed there seems to be an issue with blocking ads for apps that uses the new ads framework provided by apple in iOS 14.5.

The good news is we have a solution for it already in progress, however there’s no quick fix to the issue today. The new feature will be released later this year.

1 Like