V.5.3 not blocking ads that v.5.2.1 blocks on tablet (Android 9)

Well, I tried the current 5.3.0 from the beta channel. In terms of ad blocking, nothing has changed… 5.3 still blocks fewer ads than 5.2.1 does. Additionally, updating to that 5.3.0 from the beta channel, new problems arose. First, the update did not maintain all my settings from 5.2.1, such as using DNS over HTTPS, and notifications (it turned off the Activity notification, and turned on the Icon Badge that I had turned off). The “worst” change was that when I turned the Activity notification back on, it didn’t, even after a restart.

One other thing… on my Android 9.0 tablet, I wanted to see if a clean install helped with ad blocking and Activity (it didn’t), but this caused a new problem… by default, without asking, Blokada was installed to my SD card. This resulted in being unable to automatically restart the app after restarting the tablet. The VPN always on setting did not hold. I moved Blokada to internal storage and that problem went away. Surprisingly, when I installed (clean) 5.2.1, the same problem occured.

I can suggest a cause… 5.3 installed with backups on by default, which I turned off. I suspect that, when I did a clean install on 5.2.1, 5.3 had created a backup which stayed after I turned that “feature” off, and 5.2.1 used that backup to install where 5.3 did, on the SD card. I had to move 5.2.1 to get the VPN setting to stick there, too.

I have the same problem. With v5.2 ads were blocked while now, after last update, ads are not blocked anymore!
I have a Huawei Mate 10 Pro with Android 9 and EMUI 9.1 original (no mods or custom roms or root).
In addition, I installed v4.8.5 and it works flawlessy, but it still continues to update automatically in background, so, after a while, I found again back installed v5.0. Is there any way to stop this behaviour ?!?! Because v.5.0 doesn’t work for my device, I would like to stay with v.4.x.x but I can’t !!
PLease someone let me know a solution. Many Thanks!!

Tony…

I don’t know if it will work for you, but you said that v.5.2.1worked for you, so I would suggest going back to that. That is what I have done. It has told me once, that there is an update available, but it did not update automatically. 5.2.1 is working just fine, blocking virtual all ads (while 5.3 blocked around 25% of them), so I plan on trying new updates when available but hold on to 5.2.1 just in case.

Gregg in Sackville, NB

I already wrote it: it’s totally useless! I would like to stay with v.4.8.x but despite I answer NO to the update request, when I exit then go back to the app after a while, app had upgraded itself in background!
So, if some of the developers will read, sooner or later, this post I tell you: add a stupid SWITCH into settings to turn on or off automatic updates. THANK YOU!

1 Like

I’m sorry. I understood from your OP that 5.2.1 worked for you (“With v5.2 ads were blocked”), which is why I suggested going back to the 5.2.1 version. This is what I did…v.5.3 works fine on my Android 8.1 phone, but fails to block ads on my Android 9 tablet, so I have v.5.3 on the phone, and v.5.2.1 on the tablet. It is not an ideal solution, but at least it leaves me with a functional version of Blokada on both items.

A post was split to a new topic: Blokada stuck

I have the same problem.
It is clear that v5.3 has some bugs, v5.2.1 and earlier versions were fine. Please fix it!
I hate to clear the app data or uninstall it, because I would like to keep the ad blocked counter. I have a Huawei P Smart fig-lx1 with Android 9 and EMUI 9.1.0.

1 Like

Stefano… if you simply uninstall 5.3 without first clearing the cache or storage in the Apps settings, and then install 5.2.1, the ads blocked count will remain, I believe.

Gregg in Sackville, NB

First of all I’d like to ask you to watch your language a little.
Second of all: Blokada doesn’t get updated fully automatically if you don’t set Huawei App Gallery, F-Droid or Google Play Store to do so.
We cannot influence the behaviour of stores.

Hi,
Please check this @GreggH : Blokada for Android doesn't block ads in Chrome

We would if we knew what is going on. Unluckily no-one offered to provide us with logs and full issue descriptions yet. Please do so if you want to assist us. We need logs of folks experiencing issues with v5.3

@PrintableCharacter… I have done the “suggestions” in that thread more times than I care to remember. I have checked, double checked and repeatedly checked my settings. The situation remains no different…v.5.2.1 blocks virtually all ads, while v.5.3.0 blocks virtually no ads. No settings are changed, and to be sure, I visited the same sites with both versions, and without fail, v.5.3.0 did not block ads that v.5.2.1 did. Indeed, the Activity list in v.5.3.0 did not even show the web sites, blocked or allowed, that the v.5.2.1 Activity list indicated as blocked.

I have tried a clean install of v.5.3.0, tried updating v.5.2.1 to v.5.3.0 (both the older beta version and the current beta file) and even tried updating from v.5.2.1 to v.5.3 (Oct. 26 beta) then to v.5.3.0 (downloaded from the beta channel). Consistently, the result was the same.

The only “hint” I can offer in terms of helping solve this, is that the problem has been reported by multiple users, and in each and every case, the thing in common was Android 9. My tablet, which exhibits the problem, is on Android 9, while my phone, which has v.5.3.0 installed and ads are blocked, is running Android 8.1. It appears that the common factor is Android 9.

@PrintableCharacter… one other thing different in my case (I don’t know about others) is that my tablet does not have wireless (data/phone), only a wifi connection, where the phone has both.

I’ve downloaded Blokada from ur website and it updates automatically from version 4 to 5. Even after uninstalling V5 and reinstall V4. So it would be nice to get a switch where u could decide by urself to update or not.
Btw, i’ve got the problem that V5.3 doesn’t block ads also.
Huawei Mate20 pro with Android 10 & EMUI 10.

I would to apologise for my previous reply. However, after reading @PrintableCharacter reply, I checked that it’s Huawei AppGallery that automatically updates every version of Blokada less then 5 to v.5.1.0, because this is the last one present into the store! Infact, I have no update from 5.1.0 to 5.3.0, because that version is not present into the store.
For the moment, I’ll stay with v.5.1.0 that blocks all ads (despite without the toggle into status bar, I have to lauch it manually every time), hoping that version 5.4.0 will work good again.

It’s really the Huawei AppGallery which Updates Blokada all the time from V4 to V5. Thanks for the advice man :+1::clap::blush:

Can confirm this problem. After upgrading to 5.3 no ads are blocked. After downgrading to 5.2 ads are instantly blocked.

1 Like

RichardEB… which Android OS etc are you using. I have no problems with Android 8.1 (Blokada 5.3.0 blocks ads), but do with Android 9.0 (have to use Blokada 5.2.1 to have ads blocked).

Look everyone:
We need logs.
There’s no other way to pinpoint an issue we aren’t facing ourselves. Please provide me with your logs in PM.

@PrintableChracter

Have you ever had a noise in your engine that drove you nuts, but when you took it to a mechanic, it purred like a kitten. That’s how I feel. I spent from the 15th to the 20th (I remember because it was my older brother’s anniversary) trying every which way I could to get 5.3 to block ads. Nada. So I uninstalled it and reinstalled 5.2.1, and in a fit of pique, deleted my copy of 5.3.0.

Since then, there have been three changes… 1) Chrome updated on the 23rd of October and Google updated 2 days ago, 2) I downloaded 5.3.0 APK from the beta channel on Oct. 26th because I figured you would need a log file at some point and I would have to upgrade to it in order to get that log file, and 3) today, I enabled the two flags in Chrome for Enhanced Safe Browsing, although I did not change the resulting setting in “Privacy and Security” from the default of “Standard”.

Want to guess what happened when I update my 5.2.1 to that 5.3.0 I downloaded on the 26th? Of course, it now works precisely as it should, blocking virtually all ads without difficulty, and where the Activity list showed no red shields the first time I updated to 5.3.0, it now shows a massive amount of red shields. (I just checked to be sure I wasn’t imagining things and no, ads are being blocked all over the web.)

Gregg in Sackville, NB

Follow up… v.5.3.0 stopped blocking ads again, after a reboot. Since I posted the above, v.5.4.0 beta was released, so I tried updating 5.2.1 to that. It seemed to be working fine, until again,I rebooted my tablet, at which point, 5.4.0 stopped blocking at least 75% of ads that 5.2.1 blocked. So, backto5.2.1 I went.