Issue with Android 11, MIUI 12.1.3

Dear All, I see that Blokada stable release 5.6 doesn’t work anymore on a Mi 10, after the upgrade to Android 11 (MIUI release 12.1.3).
I’m using the same settings on an old OnePlus 6, with Android 10, and on the OP6 Blokada works flawlessy.
On the Mi 10 it seems that the OS itself bypasses the always on VPN settings, and ads are showing everywhere, apps and browser.
DNS set to Blokada DNS
Blocklist set to Energized Blu and Goodbye ads, but tried various combinations of multiple or single lists.
Removed battery optimization on the app and allowed all kind of notifications to mantain app active.
Is Android 11 the culprit?

Did you try reinstalling the application?

Yes, tried also the beta version. Same behavior.

Everything works flawlessly on my mi 8.
But that’s running android 10.
Keep us updated and maybe share a log in PM with me

Do you need the bare log that it is available in the app menu?


1 Like

Hi there,
I’ve received your logs.
It might take me some time to get back to you :slight_smile:

Thanks for your support.
Take your time and good work

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.