Blokada 4.6 disconnecting miboxs USB lan connection androidtv9

Hello,
Mibox s on Android 9 recently mibox s updated to bug fix 2696.

Download blokada 4.6 from blokada website.

Using genuine mibox s androidtv pie (9) updated from version 2604 to 2696.

On a USB lan connection and after update the mibox s to firmware version 2696, the USB lan connection in the mibox s is being disconnected.

Blokada was working fine in the mibox firmware android 9 version 2604, no mibox s Ethernet connection disconnects.

In version 2696 firmware of the mibox s v9 firmware I notice every 2 secs in the open blokada app, the blocking has a slight tick/jump constantly as if blokada is working/reacting to something in the mibox s.

I have uninstalled blokada v4.6 and the USB la ethernet connection in the mibox s does not disconnect anymore.

Your app works very well and is normally very stable.

Is there anything you could suggest to fix this.

To directly help you the best way possible please provide the following information:

  1. Where did you download Blokada from?
  2. Which device do you use? Do you use a custom ROM? Do you know which OS version you are using?
  3. Please explain the issue as detailed as possible. Also include patterns you observed (like ‘it only happens on wifi’). The more information the better.
  4. Since when are you facing this issue?
  5. Did you already try to solve the issue somehow? If so: please state what you did.
1 Like

Hello,
Does a mi box offer a system settings app? Check for a dns related system setting and turn that off

1 Like

Friendly bump :stuck_out_tongue: @Croccatcher

Hi, sorry have not come back to this and thanks for your interest.

I never found any dns settings that are visible in the settings of my mi box s.

I have also tried the new blokada version downloaded from blokada web site 4.7.3 and it seems it from the outset it blocks the usb ethernet lan connection (before on v4.6 it allowed connection for a short time and then the usb ethernet was disconnected)

Funnily enough on wifi, blokada works perfectly normal on 2.4g and 5g but this connection are slow for me and a reason I prefer the usb ethernet.

Blokada 4.6 was also working perfectly on the miboxs firmware andoid 9 v2604.

I have tried other softwares similar to blokada and they all seem to work not disconnecting the usb ethernet.

Maybe the problem is xiaomi who have changed something in their latwst firmware v2696 to prevent lan connection whilst using usb ethernet and maybe yhey should fix something.

I see on other mibox s forums, others are reporting that having a vpn installed also stops the usb lan ethernet working.

Well… Seems like an issue of the device
Keep us updated if you want to or close the thread :slight_smile: